Troubles with Win7 64 bit

Post Reply
Posts: 1
Joined: Fri Mar 11, 2011 3:33 pm
Location: Europe

Troubles with Win7 64 bit

Post by chac » Fri Mar 11, 2011 4:09 pm

I am trying to run ActivTwo system in my new PC equipped with Windows 7 64 bits and microprocessor Intel I5. However, I cannot run get any data from the system because I get the error 5000.

I downloaded and installed the Usb drivers for 64 bits from your homepage, as well as, the Beta version of ActiView 7.00 and LVRTE 8.6.1. From your forum I read a lot about this problem but at the moment not solution is suitable to my case.

I check that the driver is listed in the Windows Device Manager (as MS WinUSB driver for BioSemi ActiveTwo under MS WinUSB driver), and that the properties shows that "this devise is working properly". Moreover, I hear the plonk sound if I'm plugging in and out. When I run actiView 7.00, the USB link led is blinking 1 or 2 times before getting the error 5000.

As you recommend, I run the file Labview_DLL_SyncTest 30 from "Developers kit\C-code" folder. The next error appears:

sizeof long =4
ring buffer size = 33554432
IN PipeType (3) not bulk (2)!
*** bsif_usb_write: acquisition thread not running after 1 second
usb_write for enable handshake trouble 997
Overlapped I/O operation is in progress

Interesting is that: When I run windows XP mode (Windows virtual PC) under Win764bits, there is any problem by acquisition with Actiview 6.05 and RTE8.2. In this case the virtual USB port load the drivers for winXP 32bits.

In other computers from our lab the system works without problems. However, these pcs have WinXP 32bits.

Any ideas to solve the problem?

Site Admin
Posts: 984
Joined: Fri Mar 26, 2004 7:00 pm
Location: Amsterdam, Netherlands

Post by Coen » Fri Mar 11, 2011 4:35 pm

If your USB receiver is from the first batch (year 2003), then we may have to upgrade the firmware to ensure compatibility with the new drivers. Please provide the serial number of your AD-box, and I will check our files.

In the 64-bit case, the situation with the LabVIEW_DLL.dll is a bit different than with the 32-bit case discussed elsewhere on this forum:

- In the ActiView directory, the (32-bit) LabVIEW_DLL.dll originally packed with ActiView 700 should be present. This LabVIEW_DLL.dll should NOT be replaced by the (64-bit) LabVIEW_DLL.dll packed with the 64-bit driver (because LabVIEW 8.6.1 and its RTE are 32-bit programs)

Best regards, Coen (BioSemi)

Post Reply