LabVIEW and ActiVIEW on Mas OS Catelina

Post Reply
Posts: 1
Joined: Tue Feb 11, 2020 2:47 pm

LabVIEW and ActiVIEW on Mas OS Catelina

Post by koki »


I have a problem on launching ActiVIEW on Mac OS Catelina.
I installed LabVIEW 2019 SP1 and tried to launch ActiVIEW804, but Alert.
The message was

"Could not find the LabVIEW Runtime, you may need to install it. Do you want to visit to download the LabVIEW Runtime Engine?".

How can I solve this or I have to downgrade OS to Mojave?
If you have any knowledge, please tell me.

Thank you.

Posts: 2
Joined: Wed Feb 12, 2020 8:34 am

Re: LabVIEW and ActiVIEW on Mas OS Catelina

Post by neurospecag »

Dear Biosemi Mac Community

With the new OS Catalina for MAC it is currently not possible to run the RE 2016 from NI, nor of course ActiView that is dependent on the RE. There are a few ways of making it work:

1) If you currently have not upgraded from High Sierra or Mojave to Catalina, and run an older version Labview RE, you should first upgrade in High Sierra to RE 2016 and ActiView 804 for MAC and make sure that runs well in High Sierra or Mojave. If you can verify that, then upgrade to Catalina, and ActiView should then still run fine.

2) if you purchased a new Macbook, or MAC, with Catalina as the latest OS, then installing the RE 2016 and ActiView 804 will not work but return an error saying : "Could not find the Labview RE".

3) So, in order to make it work, you would have to either wait for Apple to release a fix that "opens" the port to run the NI RE 2016 (which will probably not happen) or follow these points to downgrade your system to Mojave and use that OS until you upgrade back to Catalina:

a) Important Note: Any iPhoto Library would not be backward compatible to Mojave – so best would be to save all the files collected (not talking about EEG obviously!) like Pages, Numbers, Keynote, or the MS Office Files like Word, Exl etc… on a external harddisk before you do the “downgrade”. Once done, proceed as follows:

b) Then to downgrade follow this link – it worked for me, others did not:

The Mojave Installer is not available in the APP Store, but have to get it from deep within Apple: ... 2828?mt=12

So all you really need to do, before reading the huge explanations in the Macpaw how to do site, I just did this:

i) Downloaded the Mojave OS (follow the link above)
ii) Move it to an external SSD that has enough space (I used the Samsung T5 SSD with 250GB) by going to TERMINAL, and then run this:
sudo /Applications/Install\ macOS\ --volume /Volumes/Samsung_T5 note: the Samsung_T5 may be called different for your attached drive, or memory stick – just jot down the name of it on the desktop – it will pop up and tell you what its name is.
iii) Boot your system (after you backed up everything!!) and press CMD R – delete the current Mac Drive, and have Mojave install….

c) If your Macbook is new, the above may not work as you anticipate. Then you should look at this page: ... to-mojave/

Again, the three most important steps would be: 1) get Mojave while it is still available and move it using TERMINAL to an external stick // 2) backup all you have (we cannot take responsibility with this email when you lose valuable data) // 3) reboot Macbook and delete the Mac Drive, and have Mojave installed as you go on.

After all done, download RE 2016 and ActiView for MAC from here: - it runs well with my Macbook.

Lastly, if all fails, and your Macbook does not run anymore, Apple has a partition on the drive holding Catalina… so you can always revert back to Catalina, but then wont be able (at least now) to run ActiView.

Hope these steps help you to use ActiView on your Mac!

Be well, Marc Mosimann

Post Reply