One or more output arguments not assigned during call to "read_24bit"

Post Reply
deheering
Posts: 2
Joined: Fri Nov 15, 2019 12:47 pm

One or more output arguments not assigned during call to "read_24bit"

Post by deheering » Fri Nov 15, 2019 12:52 pm

Good afternoon,

I have recently experienced the following error message when trying to import BDF files that could however be viewed with the BDF READING tool.
I have tried to repair it using the REPAIR tool, which has unfortunately led to the same error message.
Could you help me with this and tell me how to solve the problem?
Thanks in advance,
Adélaïde

--------------------------------------------------------------------------------------------------------

One or more output arguments not assigned during call to "read_24bit".

Error in read_biosemi_bdf>readLowLevel (line 282)
buf = read_24bit(filename, offset, numwords);

Error in read_biosemi_bdf (line 257)
buf = readLowLevel(filename, offset, epochlength*nchans); % see below in subfunction

Error in ft_read_data (line 408)
dat = read_biosemi_bdf(filename, hdr, begsample, endsample, chanindx);

Error in RLW_import_BDF (line 26)
dat=ft_read_data(filename);

Error in LW_import_BDF (line 86)
[out_datasets(filepos).header out_datasets(filepos).data message_string]=RLW_import_BDF(filename);

Error in letswave_gui>menu_callback (line 387)
[configuration,datasets]=eval(eval_st);

Error while evaluating Menu Callback

Coen
Site Admin
Posts: 980
Joined: Fri Mar 26, 2004 7:00 pm
Location: Amsterdam, Netherlands
Contact:

Re: One or more output arguments not assigned during call to "read_24bit"

Post by Coen » Mon Nov 18, 2019 2:06 pm

Test the BDF file in the following two readers:

https://www.biosemi.com/download/ToolsF ... er-808.zip
http://www.teuniz.net/edfbrowser/

If the file is properly displayed without error messages in both the above readers, then the BDF file is not corrupt.

Best regards, Coen (BioSemi)

deheering
Posts: 2
Joined: Fri Nov 15, 2019 12:47 pm

Re: One or more output arguments not assigned during call to "read_24bit"

Post by deheering » Thu Nov 21, 2019 5:38 pm

Thank you for your response.
Nothing unusual when using the two readers but still something unusual (see previous message) when trying to import the data.
My guess would be that something happened during recording that we did not notice.
Any other thought on this?
Thank you.
A--

Coen
Site Admin
Posts: 980
Joined: Fri Mar 26, 2004 7:00 pm
Location: Amsterdam, Netherlands
Contact:

Re: One or more output arguments not assigned during call to "read_24bit"

Post by Coen » Thu Nov 21, 2019 7:03 pm

If the two above readers work OK, then the file is definitely OK and nothing unusual happened during recording.

The error must be in your specific reader.

Best regards, Coen (BioSemi)

Post Reply