Automatic Start/Stop the EEG recording

Post Reply
Jiti
Posts: 5
Joined: Fri Oct 11, 2013 7:54 am

Automatic Start/Stop the EEG recording

Post by Jiti » Mon Dec 09, 2013 7:57 am

Hi,

I want to automatically start and stop saving the EEG data. As explained by Coen in various posts, I have changed the following entries in default.cfg file

PauseOff=254
PausOn=255

In my stimulus presentation file, I specify 254 and 255 as the first and the last events. When I run the presentation, the file saving (unpause) starts automatically, but it does not stop saving (pause) automatically. I am trying to figure out why is this happening and how can I solve the problem.

Some more information :
When I view the triggers (in Decimal) in ActiView, the values are shown as 1 and 0 for start/stop saving triggers. The triggers for my other events are coded as 2,3,4 etc. in the presentation file. They are shown as 253, 252, 251, repectively. Also, in ActiView each trigger succeeds '255'. For example, as follows

1 255 ....... 253 255 ....... 252 255 ..... 251 255 ...... 0 255

I do not understand what does 255 represent here after each event. Or, is there some parameter that I need to set correctly?

I'd appreciate your suggestions and answers to above problems.

Jiti

Coen
Site Admin
Posts: 965
Joined: Fri Mar 26, 2004 7:00 pm
Location: Amsterdam, Netherlands
Contact:

Re: Automatic Start/Stop the EEG recording

Post by Coen » Mon Dec 09, 2013 11:31 am

The start/stop triggers declared in the CFG should be displayed properly in the "Pause On/Off" indicator in ActiView (left sidebar with the "About" tabpage selected (if not, then the proper CFG is not loaded).

The 255 codes after each trigger indicate that the trigger lines return to High instead of Low after each trigger (check with "analog" display of triggers). Correct in Presentation, triggers lines should all be Low between the triggers.

Best regards, Coen (BioSemi)

Jiti
Posts: 5
Joined: Fri Oct 11, 2013 7:54 am

Re: Automatic Start/Stop the EEG recording

Post by Jiti » Wed Dec 11, 2013 2:39 pm

Thanks a lot, Coen. It works now.

Post Reply