Cannot run Decimator on Linux

Post Reply
HernanLG
Posts: 2
Joined: Thu Jun 16, 2016 11:42 am

Cannot run Decimator on Linux

Post by HernanLG » Thu Jun 16, 2016 11:58 am

Hi all,

I am running a 64-bit edition of MX Linux, based on the Debian stable.

I downloaded from Biosemi the list of Linux utilities, because I need to use the decimator to downsample some files. I extracted the contents of the Decimator file, and there was an executable file. There were no instructions on the readme. I tried launching the executable, both from visual file manager as well as from the terminal with ./Decimator but I get the following message:

bash: ./Decimator: No such file or directory

and from file manager:

Failed to execute child process "/home/hlabbeg1/Linux_Labview_Tools/Decimator/Decimator" (No such file or directory).

Anyone has been able to run the decimator on Linux? Any help is much appreciated.

Thanks in advance

User avatar
Gerben
Posts: 14
Joined: Fri Sep 24, 2010 4:36 pm

Re: Cannot run Decimator on Linux

Post by Gerben » Mon Jun 20, 2016 5:23 pm

Do you have the Labview runtime engine installed on your system?

All the Biosemi tools (including ActiView) require the Labview Runtime engine:

-These National Instruments packages must be installed:
labview-rte-aal-1.1-1.i386.rpm and labview85-rte-8.5-1.i386.rpm
See: http://www.ni.com/download/labview-run- ... .5/868/en/

-The location of the LabView run time must be added to the library search path:
>>export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib

-If running on a 64 bit Linux system, some additional 32 bit packages may need to be installed.
I don't know what is required on MX Linux but on 64-bit Ubuntu 14.04 LTS the following packages are required: gcc-multilib and libglu1-mesa:i386.

-On a Debian based version of linux it is necessary to convert the install files from rpm to deb with alien:
>>alien packagename.rpm

Best regards, Gerben (BioSemi)

HernanLG
Posts: 2
Joined: Thu Jun 16, 2016 11:42 am

Re: Cannot run Decimator on Linux

Post by HernanLG » Mon Jul 04, 2016 1:02 pm

Thanks for the advise. I managed to turn the rpm into deb packages (first had to turn them into tgz files).

But I am at a loss on what you mean here:

> -The location of the LabView run time must be added to the library search path:
> >>export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib

I would appreciate if you can elaborate on that. It seems to be the only thing I am missing to run the programs I need.

Thanks in advance

User avatar
Gerben
Posts: 14
Joined: Fri Sep 24, 2010 4:36 pm

Re: Cannot run Decimator on Linux

Post by Gerben » Tue Jul 05, 2016 5:48 pm

What kind of error does ./Decimator produce?
The error "No such file or directory" can occur if you system is unable to execute 32 bit applications.
Some additional packages may be required in order to execute 32 bit application.

[quote]-If running on a 64 bit Linux system, some additional 32 bit packages may need to be installed.
I don't know what is required on MX Linux but on 64-bit Ubuntu 14.04 LTS the following packages are required: gcc-multilib and libglu1-mesa:i386.[/quote]

Best regards, Gerben (BioSemi)

Post Reply